Problem child of the year - [Marine Mechanic Memes]

Problem child of the year . Here we go . * Tool for repair: best drill press

Customer states intermittent sputter / surge around 3-3900rpms 

on water test showed nothing till 30 minutes in with customer cruising at his normal speed . Removed hood to check somethings and engine will not do it with hood removed . It will only act up with hood on , trimmed in a very specific range and only at operating temp .

It is as if you hit the switch off & on several times very fast , almost like a rev limit kicking in . Gauges do not flatline like a power interruption .

Brought into shop as he had a large list of repairs and big no no's 

Replaced the 2 Mercedes truck maintenance free batteries with rotten cables and battery switch . Replaced them with Correct marine grade parts

It had A/c Delco plugs '''' WHY !?''''' Replaced them with correct factory one

Cleaned injectors and VST , did all fuel filters and lines 

Clean all engine grounds 

Crank trigger had some trash built up so I cleaned it and the flywheel and repainted the wheel 

Removed and clean intake plenum and throttle bodies -re-sycned 

Check key switch and harness , both clean and crisp

Water pump and other minor normal parts 

Still does it 

Will not do it above or below that RPM range 

He then took it to a Suzuki dealer where they drove and hooked up to it but computer showed nothing . So they also suspected the TPS and replaced it

Still does it 

Me and another local mobile company teamed up on it with MEDS and it showed nothing 

ONLY thing that is curious is TPS reads closed at closed throttle as it should but at WOT it reads 97% 

No computers show any power interruptions or injector/coil/cly drops which leads me to think its somehow mechanical or not where the ECM can detect a issue OR it happens too fast for the ECM to detect it .

THOUGHTS ?

Source: Marine Battery reviews